Sigma Alarm Issue - ScoobyNet.com - Subaru Enthusiast Forum

Notices

Sigma Alarm Issue

Reply

 
 
 
Old 10 July 2018, 02:24 PM
  #1  
Shane
Scooby Regular
Thread Starter
iTrader: (6)
 
Shane's Avatar
 
Join Date: Aug 2002
Location: East Sussex
Posts: 482
Default Sigma Alarm Issue

Thought I'd post this in case it's useful to anyone having similar problems.

For a couple of years now I've had a problem where the car wouldn't turn over after disabling the mobiliser when it had cut in, the fuel pump would prime but when the key was turned there was nothing, no clicks, no dimming of the dashboard light, if left for 15 to 20 minutes the problem would go away and the car would fire up straight away. Having had it happen to me twice in a couple of weeks I decided it was time for further investigation. I'd assumed it was the contacts on the relay in the alarm box corroding or having a build up of carbon up after 19 years so set about locating the alarm box and seeing if I could identify and then replace the relays.

First thing I found while gaining access under the dashboard was the blue earth tag in the photo below was loose, this obviously wasn't part of the original loom so nipped that up.



On to the alarm box and removed the screws securing the cover (don't think the warranty seals apply after 19 years so wasn't too bothered about breaking them).



First thing I noticed was that something was getting a bit warm.



Closer inspection showed a dry joint on one of the 10A relays in the alarm (probably the one that provides the switching current to the starter)



A quick run round with the soldering iron tidying up some of the other joints that were looking a little tired and fingers crossed, I've had no more problems since.

Worth checking if you're having problems with the supplies to either the ignition or fuel pump as these are the 2 circuits switched by the alarm.

Shane

Last edited by Shane; 10 September 2018 at 11:59 AM.
Shane is offline  
Reply With Quote
Old 10 July 2018, 11:26 PM
  #2  
johned
Scooby Regular
 
Join Date: Jan 2010
Location: derbyshire
Posts: 1,869
Default

Great info.
johned is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Scubarroo
General Technical
30
31 January 2016 06:28 PM
Amaya
Security
6
08 December 2015 03:47 PM
MrNoisy
Lighting and Other Electrical
4
09 May 2012 12:55 AM
BlueBugEye
Security
7
14 January 2011 10:41 AM
ver
Lighting and Other Electrical
1
30 August 2005 10:51 PM


Thread Tools
Search this Thread
Quick Reply: Sigma Alarm Issue


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.