wrx sti ppp stutter - ScoobyNet.com - Subaru Enthusiast Forum

Notices
ScoobyNet General General Subaru Discussion

wrx sti ppp stutter

Reply

 
 
 
Old 11 July 2018, 01:57 PM
  #1  
TOMMY_TURBO
Scooby Regular
Thread Starter
iTrader: (5)
 
TOMMY_TURBO's Avatar
 
Join Date: Nov 2008
Location: kent
Posts: 490
Default wrx sti ppp stutter

hope this is in the right place here goes iv got a 2003 wrx sti ppp it's got a slight stutter under 3k when u press throttle all the way to floor but if I unplug front lamba sensor the car is very smooth runs perfect does this sound like a faultly lamba or something else please help edited also the revs go very low to around 2/300 when coming to a stop with lamba plugged in
TOMMY_TURBO is offline  
Reply With Quote
Old 11 July 2018, 03:12 PM
  #2  
Hawkeye D
Scooby Regular
 
Join Date: Jun 2012
Location: Aldershot
Posts: 1,562
Default

Sounds like lambda then, no CEL?
Hawkeye D is offline  
Reply With Quote
Old 12 July 2018, 12:55 AM
  #3  
TOMMY_TURBO
Scooby Regular
Thread Starter
iTrader: (5)
 
TOMMY_TURBO's Avatar
 
Join Date: Nov 2008
Location: kent
Posts: 490
Default

No mate no cel wish it did have it I could find fault easy lol obviously has cel on when disconnected
TOMMY_TURBO is offline  
Reply With Quote
Old 12 July 2018, 04:50 PM
  #4  
The Trooper 1815
18 June 1815 - Waterloo
iTrader: (31)
 
The Trooper 1815's Avatar
 
Join Date: Dec 2004
Location: To the valley men!
Posts: 18,936
Default

Have you tried an OBD reader yet?
The Trooper 1815 is offline  
Reply With Quote
Old 13 July 2018, 01:05 AM
  #5  
TOMMY_TURBO
Scooby Regular
Thread Starter
iTrader: (5)
 
TOMMY_TURBO's Avatar
 
Join Date: Nov 2008
Location: kent
Posts: 490
Default

Yea tried that mate no faults
TOMMY_TURBO is offline  
Reply With Quote
Old 19 July 2018, 10:36 PM
  #6  
TOMMY_TURBO
Scooby Regular
Thread Starter
iTrader: (5)
 
TOMMY_TURBO's Avatar
 
Join Date: Nov 2008
Location: kent
Posts: 490
Default

No1 ever had same symptoms before?
TOMMY_TURBO is offline  
Reply With Quote
Old 20 July 2018, 04:14 AM
  #7  
Vxr2010
Scooby Regular
 
Join Date: Oct 2015
Location: Herts
Posts: 741
Default

Maf issue ?
Vxr2010 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TOMMY_TURBO
Engine Management and ECU Remapping
2
08 July 2018 02:07 AM
safecookie
General Technical
4
21 September 2013 01:19 AM
safecookie
General Technical
5
19 February 2012 12:28 PM
bbigman2000
General Technical
3
21 January 2006 02:32 PM
bodie
General Technical
6
19 April 2003 05:32 PM

Forum Jump

Thread Tools
Search this Thread