Notices
Middlesex Subaru Owner's Club The Official Dedicated Forum For The Middlesex Subaru Owner's Club.

Gutted!!

Old 14 March 2010, 12:36 AM
  #1  
Sketch
Scooby Regular
Thread Starter
 
Sketch's Avatar
 
Join Date: Mar 2008
Location: mostly cloud 9!
Posts: 652
Default Gutted!!

Gutted!!!!

Just went to give the Leggy a wash and passenger side BC is bangin like a **** house door in a hurricane!! can't risk it sounds really bad but had absolutely no banging or even slight knock last time I used it? was not sure so I checked all my wheel nuts!! tightened every nut possible but still banging!
thats less than 200 miles!!
Was just heading down to the Missbanzai night...................... out the feckin' window!
Sketch is offline  
Old 14 March 2010, 05:48 AM
  #2  
Budgie
Scooby Regular
iTrader: (4)
 
Join Date: Jul 2001
Location: MSOC..........middlesex subaru owners club
Posts: 10,424
Default

that dont sound good, any idea what it could be?
Budgie is offline  
Old 14 March 2010, 08:54 AM
  #3  
madisonmonkey
Scooby Senior
iTrader: (4)
 
Join Date: Sep 2003
Location: MSOC
Posts: 2,120
Default

Dodgy fitting most likely....
madisonmonkey is offline  
Old 14 March 2010, 10:19 AM
  #4  
Shiver
Scooby Regular
 
Shiver's Avatar
 
Join Date: Jul 2008
Location: MSOC
Posts: 659
Default

Mine was doing this too. Check the silver nut just underneath the damping adjuster perhaps.
Shiver is offline  
Old 14 March 2010, 03:56 PM
  #5  
rickya
Scooby Regular
iTrader: (18)
 
rickya's Avatar
 
Join Date: May 2007
Location: Herts/Middx
Posts: 6,322
Default

Might be worn ball joint
rickya is offline  
Old 14 March 2010, 04:00 PM
  #6  
mantazini
Scooby Regular
iTrader: (25)
 
mantazini's Avatar
 
Join Date: Feb 2008
Location: MSOC
Posts: 3,137
Default

200 miles......^^^
mantazini is offline  
Old 14 March 2010, 06:52 PM
  #7  
Sketch
Scooby Regular
Thread Starter
 
Sketch's Avatar
 
Join Date: Mar 2008
Location: mostly cloud 9!
Posts: 652
Default

Originally Posted by Budgie View Post
that dont sound good, any idea what it could be?
No! well I do now thanks to Matt!

Originally Posted by Shiver View Post
Mine was doing this too. Check the silver nut just underneath the damping adjuster perhaps.
Good thinking Batman!! was really loose other side as tight as, now wondering if it came loose or if it was loose from the beginning?
Must get your number again as have lost it??


Originally Posted by rickya View Post
Might be worn ball joint
That's what I thought when tightening everything else didn't help!

Thanks to Alan (Woodbutch) for being on the other end of the phone when I needed him and talking me through what I needed to do.

Russ!
Sketch is offline  
Old 14 March 2010, 09:43 PM
  #8  
Shiver
Scooby Regular
 
Shiver's Avatar
 
Join Date: Jul 2008
Location: MSOC
Posts: 659
Default

Bosh, glad I could help mate!

And thanks to Alan for talking me through something as well... we should get you a premium rate helpline number!
Shiver is offline  
Old 15 March 2010, 12:11 AM
  #9  
woodbutch
Scooby Regular
iTrader: (11)
 
woodbutch's Avatar
 
Join Date: Mar 2008
Location: In the land of the MSOC
Posts: 441
Default

Glad to help boys
woodbutch is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aaron_ions
General Technical
16
06 December 2017 05:06 PM
the shreksta
General Technical
27
02 October 2015 03:20 PM
ALi-B
Other Marques
18
28 September 2015 08:29 PM


Thread Tools
Search this Thread
Quick Reply: Gutted!!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.