Notices

97 2.0 gl misfire problems

Old 10 February 2012, 03:42 PM
  #1  
smokioak
Scooby Newbie
Thread Starter
 
Join Date: Feb 2012
Location: worksop
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Unhappy 97 2.0 gl misfire problems

hoping someone can help me had car serviced yesterday since then have misfireing problem between 1500 and 2500 rpm i have put new ht leads on checked breather pipes its not that dont think its the knock sensor as engine management lights not on if anyone can give me some ideas as to what it could be would be great i dont like it my babys poorly
smokioak is offline  
Old 10 February 2012, 03:45 PM
  #2  
SLAB
Scooby Regular
iTrader: (77)
 
Join Date: Jun 2008
Location: YORKSHIRE
Posts: 4,360
Likes: 0
Received 1 Like on 1 Post
Default

Did you change the coil pack due to the stupid idea car makers do for some reason they put coils in one of the hottest places. i have one of a 2ltr gl if you need one pm me
SLAB is offline  
Old 10 February 2012, 03:54 PM
  #3  
smokioak
Scooby Newbie
Thread Starter
 
Join Date: Feb 2012
Location: worksop
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

no i didnt my hubbys just taken it to be scaned for me so hopefully that should tell me told him to get mechanic to look at coil pack
smokioak is offline  
Old 10 February 2012, 03:56 PM
  #4  
lee67
Scooby Regular
 
Join Date: Oct 2011
Location: yorkshire
Posts: 276
Likes: 0
Received 0 Likes on 0 Posts
Default

does sound like coil pack common on em
lee67 is offline  
Old 10 February 2012, 04:11 PM
  #5  
SLAB
Scooby Regular
iTrader: (77)
 
Join Date: Jun 2008
Location: YORKSHIRE
Posts: 4,360
Likes: 0
Received 1 Like on 1 Post
Default

let me know if you need one i have one cheap as chippys
I think yours should be a black label coil pack
SLAB is offline  
Old 10 February 2012, 04:11 PM
  #6  
Turbotits
Scooby Regular
iTrader: (2)
 
Turbotits's Avatar
 
Join Date: Jan 2004
Location: Hertfordshire
Posts: 4,312
Likes: 0
Received 0 Likes on 0 Posts
Default

Take it back to whoever serviced it. If your sure the problem wasnt there before the service then the service agent should sort it
Turbotits is offline  
Old 10 February 2012, 04:12 PM
  #7  
SLAB
Scooby Regular
iTrader: (77)
 
Join Date: Jun 2008
Location: YORKSHIRE
Posts: 4,360
Likes: 0
Received 1 Like on 1 Post
Default

hey am only at Doncaster should of brought it to me could of put it on and seen if it was the coil
SLAB is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
PetrolHeadKid
Driving Dynamics
10
05 October 2015 05:19 PM
T.K
General Technical
10
02 October 2015 11:35 AM
sti 360
General Technical
6
02 October 2015 09:39 AM
the shreksta
Other Marques
26
01 October 2015 02:30 PM
IAN WR1
ScoobyNet General
8
28 September 2015 08:14 PM


Thread Tools
Search this Thread
Quick Reply: 97 2.0 gl misfire problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.