Notices
Drivetrain Gearbox, Diffs & Driveshafts etc

Engine Mounts Gone ??

Old 06 April 2019, 09:51 AM
  #1  
mus1
Scooby Regular
Thread Starter
 
Join Date: Oct 2002
Posts: 78
Default Engine Mounts Gone ??

Hi

Whilst searching for the source of my burning oil smell, I notice that when using the throttle body to rev the engine the engine rocked to the drivers side.
Does anyone know if this points to the engine mounts need replacing ?

I understand there's going to be some movement but not sure how much.
Any help advice always appreciated.

BTW the burnt oil smell appears to be coming form below the turbo !!!



mus1 is offline  
Old 06 April 2019, 11:40 AM
  #2  
scooby kid
Scooby Regular
iTrader: (6)
 
Join Date: Jul 2010
Location: hastings
Posts: 1,477
Default

Your burnt oil smell is most likely to be drivers side rocker cover gasket as it leaks down on to the very hot up pipe.. itís a very common thing.
And if your engines rocking fair amount itís most likely worn , mine did the same thing I was actually expecting it to be split but hadnít was just very worn.
I used group n mounts and have no issues .
scooby kid is offline  
Old 06 April 2019, 12:05 PM
  #3  
mus1
Scooby Regular
Thread Starter
 
Join Date: Oct 2002
Posts: 78
Default

Cheers Scooby Kid.
Rocker Cover gaskets were replaced, see my Oil Smell post. lol
I think the mount(s) have gone as it only 'dips' to the left ie drivers side, so there must be some play on that side.
I'm thinking sti/group n but did it make a lot more vibration. ??

Thanks again
mus1 is offline  
Old 06 April 2019, 05:22 PM
  #4  
scooby kid
Scooby Regular
iTrader: (6)
 
Join Date: Jul 2010
Location: hastings
Posts: 1,477
Default

Just fitting engine mounts to group n they where nice . It was the gearbox one that caused vibration
scooby kid is offline  
Old 06 April 2019, 09:15 PM
  #5  
mus1
Scooby Regular
Thread Starter
 
Join Date: Oct 2002
Posts: 78
Default

Thanks mate, appreciate you replying.
Group N it is, was there a noticeable difference in engine movement once changed.
mus1 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Paulgeorge01
General Technical
5
22 February 2017 03:45 PM
Rice Rocket
Wanted
0
16 January 2013 03:06 PM
chrome
Drivetrain
5
23 September 2005 02:34 PM
jtabraham
General Technical
5
07 April 2004 02:19 PM


Thread Tools
Search this Thread
Quick Reply: Engine Mounts Gone ??


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.