Notices

classic heater blower interior light and stereo stopped working...help?

Old 09 February 2012, 08:47 PM
  #1  
d.kenny
Scooby Regular
Thread Starter
 
Join Date: Sep 2011
Location: garage
Posts: 578
Likes: 0
Received 0 Likes on 0 Posts
Default classic heater blower interior light and stereo stopped working...help?

as i dont have an english manual can anyomne tell me what fuses to check or what the likely problem cause is?

i had 1 15amp blown in the underdash fuse box and one 15amp blown in the engine fuse box but the listed items are still not working?

anyone have any idea what it could be to get it going quickly or the correct fuse location?

cheers
d.kenny is offline  
Old 09 February 2012, 09:08 PM
  #2  
SLAB
Scooby Regular
iTrader: (77)
 
Join Date: Jun 2008
Location: YORKSHIRE
Posts: 4,360
Likes: 0
Received 1 Like on 1 Post
Default

I use to have them on a link m8 but new comp since then. I Google Subaru fuse box layout.
good luck
SLAB is offline  
Old 09 February 2012, 09:32 PM
  #3  
leecalcars
Scooby Regular
iTrader: (37)
 
leecalcars's Avatar
 
Join Date: Jan 2005
Location: never far away from my impreza
Posts: 7,843
Likes: 0
Received 0 Likes on 0 Posts
Default

Fuse 20 and 21 mate

https://www.scoobynet.com/general-te...x-diagram.html
leecalcars is offline  
Old 09 February 2012, 09:36 PM
  #4  
leecalcars
Scooby Regular
iTrader: (37)
 
leecalcars's Avatar
 
Join Date: Jan 2005
Location: never far away from my impreza
Posts: 7,843
Likes: 0
Received 0 Likes on 0 Posts
Default

leecalcars is offline  
Old 09 February 2012, 10:19 PM
  #5  
d.kenny
Scooby Regular
Thread Starter
 
Join Date: Sep 2011
Location: garage
Posts: 578
Likes: 0
Received 0 Likes on 0 Posts
Default

them fuses are both fine...its happened after i had a slight bump into a tree haha

but strange that interior lights blower and radio isnt working no?

gonna have to look in the day light

just its starting to snow and the heaters would be nice lol

i can hear the relay operating when i turn the dial from the auto to manual position just there is no action???

any other suggestions?
d.kenny is offline  
Old 10 February 2012, 02:03 PM
  #6  
d.kenny
Scooby Regular
Thread Starter
 
Join Date: Sep 2011
Location: garage
Posts: 578
Likes: 0
Received 0 Likes on 0 Posts
Default

the horn and central locking isnt working either...probably a broken wire on impact...see what happens when i have a look now!
d.kenny is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
[email protected] Developments
Full Cars Breaking For Spares
33
29 August 2017 07:18 PM
MH-Racing
Subaru Parts
18
18 October 2015 04:49 PM


Thread Tools
Search this Thread
Quick Reply: classic heater blower interior light and stereo stopped working...help?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.