Notices

Steam from my engine .. ugh!

Old 06 February 2019, 09:46 AM
  #1  
Ash Webster
Scooby Regular
Thread Starter
 
Join Date: Dec 2013
Location: Lytham St Annes
Posts: 853
Default Steam from my engine .. ugh!

The other day i noticed my engine temp creeping above halfway. Turned it off, checked the coolant level was a bit low so added some more. Was fine for a few days until driving to work today. After about 10min steam coming from the engine. smelled like coolant. Engine temp was fine in both car and guage.

Pulled over popped the hood and steam coming from right around/underneath the header tank. Radiator was boiling hot on one side and cold on the other... I'm assuming i have a block in the radiator and or header tank is goosed? Whats the best way to go about fixing these issues...

Cheers,

Ash
Ash Webster is offline  
Old 07 February 2019, 09:48 AM
  #2  
Ash Webster
Scooby Regular
Thread Starter
 
Join Date: Dec 2013
Location: Lytham St Annes
Posts: 853
Default

Got it back home after work no steam at all (didnt drive it over 30 though). temp was fine. assuming a spirited drive and slightly higher temps burst a leak somewhere. Going to pressure test the cooling system and see where the culprit is. Cant be having coolant leaks on the track!
Ash Webster is offline  
Old 07 February 2019, 10:40 AM
  #3  
trevsjwood
Scooby Regular
iTrader: (2)
 
trevsjwood's Avatar
 
Join Date: Sep 2007
Location: Northampton
Posts: 1,637
Default

as the engine has overheated, and by some way if the oem temp gauge has gone up, it's fairly certain the HG is done or weakened. Fixing the cooling system is one thing but I wouldn't go near a track or even drive much until you're 100% certain that engine is ok.
Trev
trevsjwood is offline  
Old 07 February 2019, 11:43 AM
  #4  
Ash Webster
Scooby Regular
Thread Starter
 
Join Date: Dec 2013
Location: Lytham St Annes
Posts: 853
Default

aye trev i know what youre saying - its at the garage now getting pressure checked (as i mentioned in a previous post the guy is ex subaru rally team so he knows what hes doing).

I've been unfortunate (and stupid) enough to have HGs go before in scoobs and usually its cos they are driven too long after the gauge rises and let the OEM gauge go upto max. i turned the car off instantly this time. the temp only just creeped above halfway to about 60%.

I wouldnt have thought the HG would go at 90/95 degrees but obviously steam isnt a great sign. Fingers crossed
Ash Webster is offline  
Old 07 February 2019, 07:29 PM
  #5  
trevsjwood
Scooby Regular
iTrader: (2)
 
trevsjwood's Avatar
 
Join Date: Sep 2007
Location: Northampton
Posts: 1,637
Default

you're not alone Ash, denial has cost me dear, 'twice'
hope you get a good outcome bud
trevsjwood is offline  
Old 08 February 2019, 09:20 AM
  #6  
Ash Webster
Scooby Regular
Thread Starter
 
Join Date: Dec 2013
Location: Lytham St Annes
Posts: 853
Default

clean bill of health.. pick it back up tonight.... now just the small matter of a weak turbo actuator not holding pressure over 0.8 bar
Ash Webster is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
eClaire
The Muppet Room
0
17 February 2004 01:55 PM
damian666
Non Scooby Related
12
03 November 2003 04:19 PM
IanW
The Muppet Room
13
07 July 2003 02:35 PM
CallumW
The Muppet Room
1
19 April 2002 08:43 PM
DavidBrown
Non Scooby Related
3
30 September 2001 07:09 PM


Thread Tools
Search this Thread
Quick Reply: Steam from my engine .. ugh!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.