Notices

Loss of Boost

Old 05 April 2016, 08:18 PM
  #1  
JC-Impreza
Scooby Regular
Thread Starter
 
Join Date: Oct 2015
Location: Forest of Dean
Posts: 53
Default Loss of Boost

Took my SSQV BOV off the other day and blocked up the outlet hose from the TMIC and took car for a drive hit the gas and my blocker came out on high boost. Was only 1 mile from home so trickled the car home as had very little power.

I fitted BOV back on today and the car is only boosting to approx 7 psi where before it was at 15psi.

Has the car gone into some sort of limp/get me home mode when driving with pipe unblocked? If so how do I reverse this as I am missing my boost!

Car is classic facelift uk2000 turbo saloon

Last edited by JC-Impreza; 05 April 2016 at 08:19 PM.
JC-Impreza is offline  
Old 05 April 2016, 09:19 PM
  #2  
johned
Scooby Regular
 
Join Date: Jan 2010
Location: derbyshire
Posts: 1,896
Default

Put standard BOV on and clear the ECU.
johned is offline  
Old 05 April 2016, 10:51 PM
  #3  
JC-Impreza
Scooby Regular
Thread Starter
 
Join Date: Oct 2015
Location: Forest of Dean
Posts: 53
Default

Originally Posted by johned View Post
Put standard BOV on and clear the ECU.
How do I do this?
JC-Impreza is offline  
Old 05 April 2016, 11:15 PM
  #4  
ossett2k2
Scooby Regular
iTrader: (9)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 6,237
Default

I had this happen when I stupidly fitted a bailys DV
Car went into limp and I had to reset the ecu.
Classic ecu reset:
http://www.scoobypedia.co.uk/index.p...ledge/ECUReset
ossett2k2 is offline  
Old 06 April 2016, 08:59 PM
  #5  
JC-Impreza
Scooby Regular
Thread Starter
 
Join Date: Oct 2015
Location: Forest of Dean
Posts: 53
Default

All sorted just left the battery disconnected overnight and boost is back! Happy me!
JC-Impreza is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
potter456
General Technical
5
02 March 2016 07:54 PM
SLAB
Subaru Parts
2
27 February 2016 11:51 AM
seanbaldacchino
Subaru Parts
10
24 February 2016 12:23 AM
1999wagon
Wanted
1
18 February 2016 07:28 PM
brumm
ScoobyNet General
1
16 February 2016 07:31 PM


Thread Tools
Search this Thread
Quick Reply: Loss of Boost


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.