ESL - Boost,MAFless, Antilag and Launch control tutorial - Page 2 - ScoobyNet.com - Subaru Enthusiast Forum



Engine Management and ECU Remapping This section is to discuss the various aspects of engine management modification for your Subaru.

ESL - Boost,MAFless, Antilag and Launch control tutorial

Reply
 
 
 
Thread Tools Search this Thread
Old 18 June 2017, 12:26 AM   #31
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by johnlogie View Post
If there is no pin can you not add one?
I tried but made no difference just made the engine run erraric when it was earthed but no anti lag😕
Jason Roper is offline   Reply With Quote
Old 18 June 2017, 12:28 AM   #32
johnlogie
Scooby Regular
iTrader: (4)
 
Join Date: Oct 2008
Location: Glasgow
Posts: 945
Default

Quote:
Originally Posted by Jason Roper View Post
I tried but made no difference just made the engine run erraric when it was earthed but no anti lag😕
Rich is the man to help you here mate
johnlogie is offline   Reply With Quote
Old 18 June 2017, 12:28 AM   #33
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by johnlogie View Post
I wish all this stuff make actual sense to me. I need to get into this mapping stuff lol
I have no idea what anyof that means either tbh 😕 I though all i had to do was snip a wire and earth it via a switch 😩
Jason Roper is offline   Reply With Quote
Old 18 June 2017, 12:33 AM   #34
johnlogie
Scooby Regular
iTrader: (4)
 
Join Date: Oct 2008
Location: Glasgow
Posts: 945
Default

Quote:
Originally Posted by Jason Roper View Post
I have no idea what anyof that means either tbh 😕 I though all i had to do was snip a wire and earth it via a switch 😩
That's how it sounds to me mate. I'd be the same as you that's why i don't understand why Andy didn't just do it or at least show you exactly what to do. We're not all mappers or auto electricians
johnlogie is offline   Reply With Quote
Old 18 June 2017, 12:37 AM   #35
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

Quote:
Originally Posted by johnlogie View Post
I wish all this stuff make actual sense to me. I need to get into this mapping stuff lol
It's really interesting and ESL is one of the easier ECUs to map on,user friendly so a nice way to learn.
I'm still learning the basics so only playing really,I'll only ever map my own and the car runs very well so must doing something right
ossett2k2 is offline   Reply With Quote
Old 18 June 2017, 12:41 AM   #36
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

Quote:
Originally Posted by Jason Roper View Post
I tried but made no difference just made the engine run erraric when it was earthed but no anti lag😕
Quote:
Originally Posted by Jason Roper View Post
I have no idea what anyof that means either tbh 😕 I though all i had to do was snip a wire and earth it via a switch 😩

What is your switch mask set to for ALS? When you had it wired on the pin 11 you put in?
Have you tried ALS on your map2 which is on all the time,you do know that it will make the engine feel erratic don't you?
ossett2k2 is offline   Reply With Quote
Old 18 June 2017, 12:45 AM   #37
johnlogie
Scooby Regular
iTrader: (4)
 
Join Date: Oct 2008
Location: Glasgow
Posts: 945
Default

Quote:
Originally Posted by ossett2k2 View Post
It's really interesting and ESL is one of the easier ECUs to map on,user friendly so a nice way to learn.
I'm still learning the basics so only playing really,I'll only ever map my own and the car runs very well so must doing something right
I'll need to pop down to Leeds one weekend for a few beers and a training session lol
johnlogie is offline   Reply With Quote
Old 18 June 2017, 12:57 AM   #38
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

Quote:
Originally Posted by johnlogie View Post
I'll need to pop down to Leeds one weekend for a few beers and a training session lol
Not sure I'd be the best teacher lol but your welcome mate
ossett2k2 is offline   Reply With Quote
Old 18 June 2017, 01:10 AM   #39
The Rig
Scooby Regular
iTrader: (13)
 
The Rig's Avatar
 
Join Date: Dec 2002
Posts: 7,412
Default

Set map 1 as the map you use all the time , then transfer this info to map 2 yet it has antilag on constant. When you want antilag use ignition sequence to change between maps .
The Rig is offline   Reply With Quote
Old 18 June 2017, 11:36 AM   #40
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by ossett2k2 View Post
What is your switch mask set to for ALS? When you had it wired on the pin 11 you put in?
Have you tried ALS on your map2 which is on all the time,you do know that it will make the engine feel erratic don't you?
I have no idea �� Andy mapped it i havent a clue about mapping cars �� And in map 2 its erratic but pops and bangs when you rev in map 1 there is no pops and bangs when revs come back down �� Just runs eratic
Jason Roper is offline   Reply With Quote
Old 18 June 2017, 12:18 PM   #41
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default









Jason Roper is offline   Reply With Quote
Old 18 June 2017, 12:25 PM   #42
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default



So my understanding is this is pin 11 right or am i being daft?
Jason Roper is offline   Reply With Quote
Old 19 June 2017, 12:35 PM   #43
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by ossett2k2 View Post
Not sure I'd be the best teacher lol but your welcome mate
Do these pics look correct? Im baffled now
Jason Roper is offline   Reply With Quote
Old 19 June 2017, 12:56 PM   #44
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

Yes pics are correct,you should be ok to put a wire in there and wire in a switch to ground,Andy will have set the switch mask to 16 on the map if he told you to wire the switch to pin 11.
You could have also used pin 18 B136 but would need the switch mask setting to 64 in the map,I assume you don't have the ESL cable.
Did you take the car for a drive when you grounded pin 11? No pops and bangs at all?
ossett2k2 is offline   Reply With Quote
Old 19 June 2017, 02:11 PM   #45
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by ossett2k2 View Post
Yes pics are correct,you should be ok to put a wire in there and wire in a switch to ground,Andy will have set the switch mask to 16 on the map if he told you to wire the switch to pin 11.
You could have also used pin 18 B136 but would need the switch mask setting to 64 in the map,I assume you don't have the ESL cable.
Did you take the car for a drive when you grounded pin 11? No pops and bangs at all?
No i dont have the esl cable i have no idea what i am doing so that would be a bad idea haha no i didnt drive the car, however i will try that tonight and see if it works, ano in map 2 you dont need to be driving for anti lag to work just rev and it pops and bangs.
Jason Roper is offline   Reply With Quote
Old 19 June 2017, 02:50 PM   #46
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

I don't think mine does when I just rev,might be wrong tho as I never use it,I can check tomorrow.
So in map2 where ALS is on all the time are you revving the car with throttle on and off or is your foot flat out to get pops&bangs?
ossett2k2 is offline   Reply With Quote
Old 19 June 2017, 04:24 PM   #47
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by ossett2k2 View Post
I don't think mine does when I just rev,might be wrong tho as I never use it,I can check tomorrow.
So in map2 where ALS is on all the time are you revving the car with throttle on and off or is your foot flat out to get pops&bangs?
In map 2 I just rev and when it comes back down it pops and bangs!
If i hold my foot down with handbreak on it hits lc at 4k revs and splutters
Jason Roper is offline   Reply With Quote
Old 19 June 2017, 04:40 PM   #48
SmurfyBhoy
Scooby Regular
 
SmurfyBhoy's Avatar
 
Join Date: May 2014
Location: Glasgow
Posts: 1,231
Default

Romraider is great for tuning advise,

Dunno if this helps u ??

http://www.romraider.com/forum/viewt...hp?f=36&t=9768

Rigging up switches
SmurfyBhoy is offline   Reply With Quote
Old 19 June 2017, 04:43 PM   #49
SmurfyBhoy
Scooby Regular
 
SmurfyBhoy's Avatar
 
Join Date: May 2014
Location: Glasgow
Posts: 1,231
Default

Also a good Facebook group thats handy called Guild of Subaru Tuners
SmurfyBhoy is offline   Reply With Quote
Old 20 June 2017, 12:38 AM   #50
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by ossett2k2 View Post
I don't think mine does when I just rev,might be wrong tho as I never use it,I can check tomorrow.
So in map2 where ALS is on all the time are you revving the car with throttle on and off or is your foot flat out to get pops&bangs?
Ok so I attempted again today and its working!!!!! However when i activate antilag on the switch i hit 6k revs and it hits a cut very similar to launch controll its strange! If i turn it off it revs to 8k im baffled!
Jason Roper is offline   Reply With Quote
Old 20 June 2017, 02:08 AM   #51
johnlogie
Scooby Regular
iTrader: (4)
 
Join Date: Oct 2008
Location: Glasgow
Posts: 945
Default

Doesn't that mean that when anti lag is on so is launch and it's set at 6k?
My launch on Alcatek is set at about 5.5k in first and als is on or off by switch
johnlogie is offline   Reply With Quote
Old 20 June 2017, 03:04 AM   #52
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by johnlogie View Post
Doesn't that mean that when anti lag is on so is launch and it's set at 6k?
My launch on Alcatek is set at about 5.5k in first and als is on or off by switch
Well my launch control is set at 4k when handbrake is on, but its like is kicks in again at 6k its weird
Jason Roper is offline   Reply With Quote
Old 20 June 2017, 08:40 AM   #53
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

Not sure why it would fuel cut at 6k,is this when you're driving and in gear?
LC will be set to be on all the time and default is 4k(can be changed in the map)
You can also put LC on a switch but again you would need to go into the map to change setting.
I've not played with mine,infact never launched the car yet.
ossett2k2 is offline   Reply With Quote
Old 20 June 2017, 02:21 PM   #54
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by ossett2k2 View Post
Not sure why it would fuel cut at 6k,is this when you're driving and in gear?
LC will be set to be on all the time and default is 4k(can be changed in the map)
You can also put LC on a switch but again you would need to go into the map to change setting.
I've not played with mine,infact never launched the car yet.
Jason Roper is offline   Reply With Quote
Old 20 June 2017, 04:52 PM   #55
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

These are the tables for ALS
There is a fuel cut table which can be adjusted to cut fuel at whatever revs and throttle position you want,maybe Andy set yours to cut at 6k?
You would only know by asking the mapper or plugging it in to see the tables(cable required)

ossett2k2 is offline   Reply With Quote
Old 20 June 2017, 05:03 PM   #56
Jason Roper
Scooby Newbie
 
Join Date: Jun 2017
Location: newcastle
Posts: 17
Default

Quote:
Originally Posted by ossett2k2 View Post
These are the tables for ALS
There is a fuel cut table which can be adjusted to cut fuel at whatever revs and throttle position you want,maybe Andy set yours to cut at 6k?
You would only know by asking the mapper or plugging it in to see the tables(cable required)


Jason Roper is offline   Reply With Quote
Old 20 June 2017, 05:13 PM   #57
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,078
Default

You seem to be getting a good response from you're mapper(refreshing change )your ALS is now working on the switch you've put on,looks like Andy has left the ALS tables as default(as shown in my pics)
Only thing I can think is that,as shown on your vid clip that you switch to ALS and instantly go WOT.
I would try driving for a bit with ALS on then try a WOT to see if you can get past 6k.

Last edited by ossett2k2; 20 June 2017 at 05:14 PM.
ossett2k2 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 (54) Blue JDM Widetrack STi Fresh Import KAS35RSTI Subaru 21 03 February 2016 04:13 PM
esl wanted for v3 sti on a p reg scoob1985 Wanted 5 13 October 2015 04:02 PM
Greddy trust boost gauge psport Subaru Parts 3 04 October 2015 07:35 PM
Subaru full forged 2.1 blobeye 468 bhp Ganz1983 Subaru 5 02 October 2015 09:22 AM
Clean Boost Solenoid mistermexican General Technical 2 01 October 2015 04:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT +1. The time now is 04:38 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: