Subaru Discussion Forums

Go Back   ScoobyNet > Technical / Subaru Modifications > General Technical
Sign in using an external account
Register Forgot Password?


Welcome to ScoobyNet.com!
Subaru forum
Welcome to the ScoobyNet.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Reply
 
 
 
 
Thread Tools Search this Thread
Old 11 June 2010, 21:00   #1
welder029
Scooby Regular
 
Trader Score: (0)
Join Date: May 2008
Posts: 68
Default P0420 Catalyst System Efficiency Below Threshold

hi need help basically driving along and the engine light came on but car was still running ok, hooked it up to a fault reader got the following code <P0420 Catalyst System Efficiency Below Threshold >once the code was reset the car stalled after it was started a few times plus the idle wasnt brill plus alot of pops and bangs when the car is reved slightly so basically over fuelling, and ideas ? put a multimeter on the front lamda sensor where it plugs in and gettin a stable 3.8v does that mean it knackered ? car has a full decat 3" system and a blitz dump valve dunno if this would cause this , its an 2002 sti, cheers in advance for the help
welder029 is offline   Reply With Quote
Old 12 June 2010, 00:03   #2
r1c
Scooby Regular
 
Trader Score: (9)
Join Date: May 2009
Location: cambridgeshire
Posts: 1,126
Default

Hi, A cat efficiency code will generally tell you your cat is fupared. But as say you are running a decat system. How long have you been de catted. ? Have you been mapped?? Can you tell us a bit more about your car, what mods etc?
r1c is offline   Reply With Quote
Old 12 June 2010, 09:04   #3
dynamix
RaceDynamix Ecu Remapping
 
dynamix's Avatar
 
Trader Score: (3)
Join Date: Feb 2006
Location: near you
Posts: 9,718
racedynamix racedynamix
Send a message via MSN to dynamix
This is my Scooby.  To set up your own Scooby, go to your user cp, and click 'Edit Settings'.
Default

That code will keep popping up as you havent got a cat.

A remap will be able to switch it off permenantly (and get a lot more power/torque for you)
__________________

Duncan [ RaceDynamix ]
email: duncan@racedynamix.com
tel: 07540 185754

Mobile Custom Remaps for: All Impreza/Forester 1999-2014 | BRZ | Classics 92-98 (New ESL Twin Maps / Mafless) | Syvecs | Alcatek | Ecutek & Racerom

Road or Dyno Mapping available across the UK

BC Racing Time Attack on Facebook
Follow RaceDynamix on Facebook
Follow RaceDynamix on Twitter
dynamix is offline   Reply With Quote
Old 12 June 2010, 09:28   #4
welder029
Scooby Regular
 
Trader Score: (0)
Join Date: May 2008
Posts: 68
Default

its been running a full decat for at least 4 years and a full 3" for the past 2, the car was remapped thro re motorosport in leeds, so basically a dont think its because a dont have a decat, guy before me put a RCM ceramic coated downpipe and wraped headers plus got it remapped to 330bhp said the guy that did the remap was the scoobyclinic mapper thats where the rolling road graph came from so ad think they would have tweaked in what you said , basically thinking its 1 of my lamda sensors
welder029 is offline   Reply With Quote
Old 12 June 2010, 09:32   #5
dynamix
RaceDynamix Ecu Remapping
 
dynamix's Avatar
 
Trader Score: (3)
Join Date: Feb 2006
Location: near you
Posts: 9,718
racedynamix racedynamix
Send a message via MSN to dynamix
This is my Scooby.  To set up your own Scooby, go to your user cp, and click 'Edit Settings'.
Default

If it had been remapped with the decat on the mapper would/should have switched the CEL light off for it.

It is coming on because there is no cat. So your map needs changing to suit. It will keep coming on because of that - no other reason.
__________________

Duncan [ RaceDynamix ]
email: duncan@racedynamix.com
tel: 07540 185754

Mobile Custom Remaps for: All Impreza/Forester 1999-2014 | BRZ | Classics 92-98 (New ESL Twin Maps / Mafless) | Syvecs | Alcatek | Ecutek & Racerom

Road or Dyno Mapping available across the UK

BC Racing Time Attack on Facebook
Follow RaceDynamix on Facebook
Follow RaceDynamix on Twitter
dynamix is offline   Reply With Quote
Old 12 June 2010, 09:47   #6
welder029
Scooby Regular
 
Trader Score: (0)
Join Date: May 2008
Posts: 68
Default

why has it ran fine for 2 years ?surely it must have been mapped in or it would have come on by now , plus it wants to stall when first started and its over fuelling can smell it and here it pop when u rev it
welder029 is offline   Reply With Quote
Old 12 June 2010, 10:00   #7
dynamix
RaceDynamix Ecu Remapping
 
dynamix's Avatar
 
Trader Score: (3)
Join Date: Feb 2006
Location: near you
Posts: 9,718
racedynamix racedynamix
Send a message via MSN to dynamix
This is my Scooby.  To set up your own Scooby, go to your user cp, and click 'Edit Settings'.
Default

The front lambda sensor would throw a different fault code to P0420 from your symptoms it sounds like that is faulty.
__________________

Duncan [ RaceDynamix ]
email: duncan@racedynamix.com
tel: 07540 185754

Mobile Custom Remaps for: All Impreza/Forester 1999-2014 | BRZ | Classics 92-98 (New ESL Twin Maps / Mafless) | Syvecs | Alcatek | Ecutek & Racerom

Road or Dyno Mapping available across the UK

BC Racing Time Attack on Facebook
Follow RaceDynamix on Facebook
Follow RaceDynamix on Twitter
dynamix is offline   Reply With Quote
Old 12 June 2010, 10:13   #8
welder029
Scooby Regular
 
Trader Score: (0)
Join Date: May 2008
Posts: 68
Default

should the voltage on the front lamda sensor be stable it 3.8 or should it go up and down ?
welder029 is offline   Reply With Quote
Old 12 June 2010, 10:13
 
 
 
Reply

Tags
2006, car, catalyst, efficiency, exhaust, forester, fuel, impreza, p0420, smell, sport, stalls, starts, subaru, system, threshold


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off
Forum Jump



All times are GMT +1. The time now is 04:59.


Important - Opinions expressed are not necessarily the opinions of ScoobyNet or any individuals directly or indirectly involved in this website or the companies and individuals associated with it. No responsibility is taken or assumed for any comments or statements made on this or any associated or relating bulletin board. Your personal information will be kept private except to comply with applicable laws or valid legal reasons.
Email Backups