Notices
Northern (England) Northern Meetings & Events

brakes

Old 30 June 2019, 09:55 PM
  #1  
obey1
Scooby Regular
Thread Starter
iTrader: (24)
 
Join Date: Dec 2006
Location: oldham
Posts: 904
Likes: 0
Received 0 Likes on 0 Posts
Default brakes

hi members, i have problem and doing my head in bought some alcons prodrive with discs and pads , had installed and ran for a while then got brake judder so ord some new discs to be fitted 2pc not cheap then ran for a while same judder at braking at speed so had a skim of discs and new pads ebc blue same again ran a while and now judder again so dont know what the problem could be as now same again could be installed and hubs not cleaned or callipers or anything else , before this was running brembo on my wr1 no issue any help would be appreciated will it need a strip down and anybody manchester to look at them
obey1 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Aztec Performance Ltd
Trader Announcements
34
06 July 2011 10:14 PM
Aztec Performance Ltd
Group Buys
3
19 October 2010 06:54 PM
The Grift
Wheels, Tyres & Brakes
2
18 December 2004 08:10 PM
WRX_Rich
Wheels, Tyres & Brakes
1
29 October 2004 06:40 PM
USAchap
Wanted
0
07 August 2002 02:16 AM


Thread Tools
Search this Thread
Quick Reply: brakes


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.