Notices

Miss firing problems can anyone help?

Old 20 April 2019, 08:38 AM
  #1  
Stevgreenscoob
Scooby Newbie
Thread Starter
 
Join Date: Apr 2019
Location: KEITH
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Miss firing problems can anyone help?

Hi I have a problem with my gc8 face-lift with it miss firing. Iv had the car lying for about a year not doing much. Iv started to get it going again and so far iv replace the coilpack leads and mass air flow with the diagnostic saying its the mass sensor. Its cleared on the diognosis bus still missing. All parts are genuine resulting in the missing not being so bad but still missing. Iv got spark plugs coming but the ones I have in are quite new. I would be much obliged if I could get some recommendations

Thanks
Stevgreenscoob is offline  
Old 20 April 2019, 09:57 AM
  #2  
ossett2k2
Scooby Regular
iTrader: (9)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 6,239
Likes: 0
Received 0 Likes on 0 Posts
Default

Possibly bad fuel if it's been sat for over a year?
What year/model and is it standard?
Also check pipework for splits etc

Last edited by ossett2k2; 20 April 2019 at 10:00 AM.
ossett2k2 is offline  
Old 20 April 2019, 03:23 PM
  #3  
Stevgreenscoob
Scooby Newbie
Thread Starter
 
Join Date: Apr 2019
Location: KEITH
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Miss fire

I put a half tank of fresh in. May be I need to give it a good run? It gets worse the more throttle you give it. Its as if its struggling to run at full throttle. I'll give it a decent run tonight and see if it gets any better.
Stevgreenscoob is offline  
Old 20 April 2019, 03:25 PM
  #4  
Stevgreenscoob
Scooby Newbie
Thread Starter
 
Join Date: Apr 2019
Location: KEITH
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Miss fire

Yes it's standard and it's a 99 with 116k
Stevgreenscoob is offline  
Old 21 April 2019, 09:29 AM
  #5  
Marky1968
Scooby Regular
 
Marky1968's Avatar
 
Join Date: Jan 2019
Location: Somerset
Posts: 113
Likes: 0
Received 0 Likes on 0 Posts
Default

Maybe the 02 sensor, but I guess that would of flagged up on the diagnostic.

But I agree with ossett2k2, reckon its because your car has sat around for a year.
Marky1968 is offline  
Old 21 April 2019, 09:47 AM
  #6  
ossett2k2
Scooby Regular
iTrader: (9)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 6,239
Likes: 0
Received 0 Likes on 0 Posts
Default

Also any fuel trims and knock control tables will have been reset so giving it a good run would see the car run better.
ossett2k2 is offline  
Old 21 April 2019, 09:56 AM
  #7  
Marky1968
Scooby Regular
 
Marky1968's Avatar
 
Join Date: Jan 2019
Location: Somerset
Posts: 113
Likes: 0
Received 0 Likes on 0 Posts
Smile

Originally Posted by ossett2k2 View Post
Also any fuel trims and knock control tables will have been reset so giving it a good run would see the car run better.
Yes mate, I think your car maybe just needs a good run, and hopefully all shall be good for you
Marky1968 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aboutime11
General Technical
0
21 February 2011 07:49 PM
TrueSTI man
Drivetrain
1
13 July 2004 10:02 PM
Figment
The Muppet Room
7
04 October 2003 03:46 PM
Disco
Drivetrain
18
06 May 2003 05:53 AM
skoobidude
ScoobyNet General
2
16 March 2002 09:47 PM


Thread Tools
Search this Thread
Quick Reply: Miss firing problems can anyone help?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.