Central locking problem - ScoobyNet.com - Subaru Enthusiast Forum



Central locking problem

Reply
 
 
 
Thread Tools Search this Thread
Old 09 August 2017, 11:23 PM   #1
Westo92
Scooby Newbie
Thread Starter
 
Join Date: Aug 2017
Location: York
Posts: 9
Default Central locking problem

Hi guys,

Recently bought a blob JDM STI and noticed the central locking doesn't work, not on the fob, and not from the key in the drivers door either!

Is this a common thing? And has anyone else come across this problem and solved it?
Westo92 is offline   Reply With Quote
Old 09 August 2017, 11:30 PM   #2
ossett2k2
Scooby Regular
iTrader: (8)
 
ossett2k2's Avatar
 
Join Date: Jan 2007
Location: Leeds
Posts: 5,529
Default

Can you hear anything click/clunk when you try?
Could be a broken actuator or just a rod that's popped off.
Had this on my classic and new actuator was about 12
ossett2k2 is offline   Reply With Quote
Old 09 August 2017, 11:47 PM   #3
Westo92
Scooby Newbie
Thread Starter
 
Join Date: Aug 2017
Location: York
Posts: 9
Default

No clunk or any noise. Just like locking a car that has no battery on it?
Westo92 is offline   Reply With Quote
Old 12 August 2017, 11:21 AM   #4
Westo92
Scooby Newbie
Thread Starter
 
Join Date: Aug 2017
Location: York
Posts: 9
Default

Does anyone know where the relay and fuses are for it?
Westo92 is offline   Reply With Quote
Old 12 August 2017, 12:15 PM   #5
Don Clark
Scooby Regular
 
Don Clark's Avatar
 
Join Date: Feb 2003
Location: Harpenden
Posts: 3,602
Default

There is no relay "as such" but a keyless entry control module.

If it's anything like the European setup (MY05 RHD non double lock), it is supplied by 2 fuses in the main fuse board (engine bay) and 1 in the fuse board by the drivers right knee.

It can also be linked into the room light circuit and power window switch.
Don Clark is offline   Reply With Quote
Old 21 August 2017, 04:19 PM   #6
Westo92
Scooby Newbie
Thread Starter
 
Join Date: Aug 2017
Location: York
Posts: 9
Default

Thanks for the help guys

After checking bits and bobs as you mentioned it turned out to be a faulti microswitch. I'm told it shouldn't lock on the key, but it does with the fob so it'll do for me
Westo92 is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT +1. The time now is 10:36 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: